Friday, 14 October 2011

wiismui.dll not found when adding components to Windows Server 2003

Happened when I tried to add\remove Windows Components to Windows Server 2003 R2 x64, after it was deployed and after Service Pack 2 was applied to it. Needed to add Application Server -> Internet Information Server (IIS).
Everything went OK but then Windows Components Wizard complained that it couldn't find wiismui.dll - asked me to insert the compact disk labeled 'Windows Server 2003 Standard x64 Edition CD-ROM' and still didn't find the file when I did browse... to the location of i386 folder.

The solution was to download the executable for the Service Pack 2, unpack it and point to it, instead of original i386. TO unpack it - run it in command prompt with /x option

The location for "Windows Server 2003 Service Pack 2 for x64 Editions" is:

UPDATE: when the above didn't help I had to copy the contents of original i386 folder from Windows 2003 Server DVD, renaming all files - prepending w. So all names started with w. Then pointed the wizard to resulting folder. For some files had to do some other renaming, i.e. saved appsrv.ms_ as appsrv64.ms_

UPDATE2: On another VM, same problem. Helped to have i386 folders from 32 bit version, 64 bit version with and without service packs.


  1. there was another piece of the puzzle that I forgot to mention - and then forgot what it was ;(

  2. This didn't solve the problem for me. No dll after unpacking either.

  3. I vaguely remember now that real problem was installer prepending all file names with "w" - so iismui.ddl turned to wiismui.dll.
    Thanks for reminding me of the issue - I will post an update soon